xbox-scene.com archived forum

Author Topic: 360 Issues  (Read 52 times)

Stefan Leroux

  • Archived-User
  • Newbie
  • *
  • Posts: 140
    • View Profile
360 Issues
« on: July 24, 2007, 05:06:00 PM »

Hey folks.  I dont know if I'm in the right place, but I guessed its a pretty general query if there is even a modicom of truth to the "alledged" 360 problems others have experienced.

Anyway, I've just recently started having issues with my Xbox 360.  I've had it for about 6 months now, and it was bought second hand.  I was actually working at the store I bought it from, alongside the original owner, so I do actually know its history.  Basically, bought at launch, used for a couple months, then pawned.  It was stored in the shop until the boss finally decided to get rid of it, so I got it, cheap.

But I digress, the problems I'm having have been a little odd.  The drive has started refusing to open.  It seems to eject a tiny amount, but then it stops, and cant go any further.  This started doing it 3 times at first, then would eject, but now its taking forever before I can even insert a disc.  I did have it vertical beside my TV but have now made it horizontal to attempt to resolve a little.  Its working so far, but I'm still a little worried.

As well as this, I've had times where it refuses to read discs, loading them to the "Insert this disc in a 360 console".  Theres also been times where it wont turn on from the controllers, or register them to it.  The only way I've solved this is by turning it off and leaving it for a while.

I've also had the problem earlier, of the RRoD.  I have no idea why, as it just does it, either in the middle of playing Hitman Blood Money: Flatline level, although I cant see taht that should, or even could affect it.

Lastly, is the issue I've been most bothered by.  I recently got Lost Planet, and can't do level 2, because I get a "This disc cannot be read" error come up AFTER I complete the level, but before it saves.  This has happened a few times, and the only thing I've noticed is that the drive spins down before the error comes up.  

Now, I realise theres a lot in here, and I'm quite possibly worrying too much, but just in case... Does anyone know of any similar issues, or have any idea to resolve this?  I dont really know how I could survive without my box.

Cheers guys
Logged

Havok

  • Archived-User
  • Newbie
  • *
  • Posts: 1105
    • View Profile
360 Issues
« Reply #1 on: July 24, 2007, 11:27:00 PM »

If it is unmodded and they warranty sticker is still intact.. call up MS.. describe all the problems and they will send you a new box (well refurb)...

You will probably be without it for a month.. but it should work fine when you get it back.
Logged

twistedsymphony

  • Archived-User
  • Newbie
  • *
  • Posts: 6955
    • View Profile
360 Issues
« Reply #2 on: July 25, 2007, 02:22:00 PM »

yup if it RRODs you you can send it in... Launch units are still under waranty.

it sounds like a basket case but I would venture a guess that the southbridge is toast considering that's what manages all of the I/O devices like the wirelessboard, DVD drive etc.

Either way MS should fit it free of charge.


... also moving to the general hardware form.
Logged