xbox-scene.com archived forum

Author Topic: Avisynth Script And Wmenc Errors  (Read 124 times)

Dagosd

  • Archived-User
  • Newbie
  • *
  • Posts: 1
    • View Profile
Avisynth Script And Wmenc Errors
« on: February 02, 2020, 08:12:00 PM »

I am attempting to encode to Windows Media Professional 10 with WMEnc, but the I keep getting an error "Failed(hr=0x00d0bc6) in converter.Initial( EncParams.szIn, FALSE, EncParams.szOut, EncParams.pProfile, FALSE, TRUE, FALSE, -1)" ffdshow is set to 5 channels with LFE selected.


I've cleaned my systems of Codecs. I reinstalled Windows 7 Codecs.
Installed Windows Media Codec, Expression for encoding.

I demux and extracted DTS with MKVextract.

I then used Tranzcode, 6 mono, and output to wav.
After I encoded with Belight to AC3.
Remux the AC3 with the MKV ( Is there anyway, at this step, without remuxing for WMEnc with Avisynth script to  extract the ac3 for encoding into Windows Professional Audio?

I created an avs file which contained "DirectShowSource("I:\Downloads\Movies\Project.mkv")". (am I missing something in the script?)
Selected the input AVS file, selected output, unselected "Use Video" and set it to "Windows Audio Professional 10 384kbps, 48kz, 5.1 channel 24bit CBR"

And encode
Get error "Failed(hr=0x00d0bc6) in converter.Initial( EncParams.szIn, FALSE, EncParams.szOut, EncParams.pProfile, FALSE, TRUE, FALSE, -1)"


What is this error? Could it be the remux with the MKV? Alternatively, is there anything out there that would convert AC3 to Windows Media Audio? Perhaps a script with Avisynth?


Logged