archived forum

Please login or register.

Login with username, password and session length
Advanced search  

News: forum restored.  registration disabled.  thanks to xboxexpert for the db dump and netham45 for cleaning it up!

Pages: 1 2 3 [4]

Author Topic: The Art Of Hotswapping  (Read 1862 times)


  • Guest
The Art Of Hotswapping
« Reply #45 on: April 17, 2008, 10:22:59 PM »

xboxhdm will inform you if the hdd is locked with a message "Your Xbox drive is locked" so I don't think it's an issue with unlocking since you didn't get that message.
So some obvious things first:
1. Is there power to your hdd? From PC or xbox?
2. It is also possible during hotswapping you have somehow damaged the hdd. If you reconnect back the hdd to the xbox and power up, is it working still? Can you go to ms dash?
3. You could also type dmesg | grep hda at xboxhdm prompt to see if xboxhdm can see your hdd.

1. Yes there is power from the xbox I do not unplug the power cable from the xbox hdd just the ide cable to switch out.
2. Hdd is not damaged because I can still go into the ms dash and play music and go into my saves.
3. I will try that to see if it will work but at this moment I am unsure. But what woulD I do if it does not see my hdd?



  • Guest
The Art Of Hotswapping
« Reply #46 on: April 18, 2008, 07:47:09 PM »

If you really can't get xboxhdm to recognize your hdd, try using xplorer360 in Windows instead. You still need to hotswap before hand. Partition 3 is C drive , Partition 4 is E drive. Backup contents of these 2 partitions first. Then delete everything away in partition 3. Kingroach's installer creates 2 folders: C and E. Use the contents of these folders: C to partition 3, E to partition 4 to copy over.

Edited by ldotsfan, 19 April 2008 - 03:48 AM.



  • Guest
The Art Of Hotswapping
« Reply #47 on: September 22, 2008, 01:44:21 AM »

I can't lock the hard drive because xboxhdm says it's frozen.  Also my original xbox hard drive can't be locked either for the same reason.  So I guess I'm basically screwed, unless someone knows how to get around this whole frozen hard drive problem.



  • Guest
The Art Of Hotswapping
« Reply #48 on: September 22, 2008, 10:41:36 AM »

how did you manage to unlock the original hdd?



  • Guest
The Art Of Hotswapping
« Reply #49 on: September 26, 2008, 12:32:55 PM »

Thanks for this awesome tutorial. I just hotswapped my hdd and hacked my xbox.



  • Guest
The Art Of Hotswapping
« Reply #50 on: October 18, 2008, 09:53:27 PM »

Not sure what i'm doing wrong here, I followed the instructions to the T as far as I know.

1) Downloaded XBOXHDM
2) Downloaded UXE Complete v 0.2.2
3) Ran both 71-fonts-install and nkpatcher-06-install from within the "support" folder
4) Copied the contents of uxe-c-replace to xboxhdm\linux\C
5) Copied the contents of place-on-e to xboxhdm\linux\E
Which left the following directory structures for the ISO

E/ROOT/skin/Project Mayhem II/loading.jpg
E/ROOT/skin/Project Mayhem II/menu.jpg
/Project Mayhem II/skin.ini

For a total disk size of 16,842,752 bytes

6) Burned the iso on memorex DVD+R at 1x
7) Disconnected IDE to DVD on xbox
8) Connected molex from pc to hd on xbox
9) DVD on pc set to slave on secondary IDE, DVD inserted
10) Turned on pc, turned on xbox which is connected to tv
11) Immediately after x opens on tv, never see MS logo on bottom, goes directly to error 12
12) Disconnected IDE from xbox to HD
13) Connected primary IDE from pc to xbox
14) Select option 2 from XBOXHDM, loading sequence ensues
15) At prompt, typed "xbrowser" and received following error

"looking for cd-rom in /dev/hda"
"looking for cd-rom in /dev/hdb" and so on until "/dev/hdt"
"linux cd not found"

16) At prompt typed "xboxhd" and received following error

tries to mount cd image on xboxhdm but fails, "no such device or address"

Same results even if I had the pc dvd set as slave on promary IDE

I've not once seen any error regarding the hard drive being locked

Please help, have been beating my brains out trying to figure out what i'm doing wrong.




  • Guest
The Art Of Hotswapping
« Reply #51 on: October 19, 2008, 02:52:05 AM »


dvd on pc should be set to master on the secundary ide controller. So your dvd drive should not be connected to the same cable as the xbox harddisk.

your pc harddisk should not be connected to the setup.

I can't help you with the hotswap. Apparently, there are a couple of different methods. I have no idea how xboxhdm reacts when the disk is not unlocked. You could easily try it out if you simply connect the disk to the pc without hotswapping.




  • Guest
The Art Of Hotswapping
« Reply #52 on: April 07, 2009, 10:06:15 PM »

I have read thru several posts and tutorials on the subject of softmodding, i have one question. My old Xbox that has been in a closet forever stopped working about 2 yrs. ago. it loads up to the Xbox screen with the big green "X" however the white microsoft letters never appear. One time, after a looooong time, it went to an error code 13, but never since. Can this still be modded? if so can someone point me in the right direction. Thanks much!



  • Guest
The Art Of Hotswapping
« Reply #53 on: March 12, 2010, 11:23:31 PM »

okay.. I'm having problems with the hot swap.

I don't know if it's because my drive is not being unlocked or if it's corrupt?

the xboxhd can't seem to find the xbox-partition table.

It can easily find the drive, but when I run "xbrowser" at the end it says no xbox partition was found.

Now I also noticed when im booting up and after I press 1 for VGA. It shows a few disk read error or disk drive status error and then says things about resetting.

Again.. I don't know if this is due to the drive still being locked?

I tried everything so far.

Swapping from MS dash.. with a music file played and paused.
I've tried taking the cd/dvd drive IDE out and hoping the error would unlock the drive.

I just need some help. I spent all day trying to get past this damn step, and have NO idea why.

i'm sorry but i'm jus a noob at this.

Here is my current situation/problem:
I attempted to hotswamp(not sure if i did it right or not, I've tried error 11, no dvd ide, gameplay, music, and the 8 sec count).  When I think I did it successfully I would type 1 to enter vga mode and it would give me picture 1. Other times it would read unknown patrition. I'm wondering if the HD is still locked in picure 1.
I bought my xbox the 2nd year it came out and played halo2  on it.

Also if it helps anyone to help me, my computer has 2 SATA HD connceted by I tried eliminating that as a factor for the problem by disconnecting the SATA connection on the mother board. My cd-rom drive is connected by a seperate ribbion than the one that IDE that is being used to connect to the xbox HD.

I think that's all the information I have about my situation, been trying this for a few months(a few days each month). I'm really hoping to softmod my xbox. Thanks in advance, and just thanks for taking to read my problem.

Picture 1:
IPB Image
Click to enlarge.
Thanks in advance smile.gif

That picture is the same errors I get in the beggining. but I eventually get to the command prompt.
Seems like xboxhd can't find a xbox partition table.. I don't know if it's because the drive isnt fully unlocked?



  • Guest
The Art Of Hotswapping
« Reply #54 on: March 13, 2010, 12:06:54 AM »

Okay.. after trying all day.

My final try worked!!!

I tried the option with the dvd/cd IDE unhooked and matching the red light. I don't think it worked.

So once again I tried the music play and pausing.. and what ya know... it finally actually works!

I got unleash all installed. Now it's time to FTP and get XBMC on it.

BTW, for those getting the errors in the picture. I was right, it's because the drive is still locked so the partition cannot be read or written too. Therefore you will get the software not finding the xbox partition table.

Do it on how I did it. Instead of typing xbrowser, try xboxhd. It will TELL u if your HD is still locked or not. I tried the command for the hell of it and noticed it told me my drive was still locked. So I tried a few more times and it stated it was unlocked and i exited and tried the xbrowser command.. and BAM! It installs.

Edited by Harryt223, 13 March 2010 - 09:19 AM.



  • Guest
The Art Of Hotswapping
« Reply #55 on: July 16, 2010, 11:08:56 AM »

Yes, another user who has hotswapping problems!

So, I have almost tried any possible option so far (not including the one where you dance around it for five minutes and pour magical sand over the ribbon cables at a precise moment).

I have used three different systems so far (And one of them actually fried! I think the disk controller is broken but the system is way overdue anyway!)
Tried to force the xbox drive as a MASTER with a jumper.
Tried the ERROR12 method, playing music, gaming, you name it.

So far I think that the only problem is a solid method of unlocking it.
I get those read errors at bootup (As shown in that image, about close to 200 lines to prove me that one thing is wrong, geez). I do get the drive to show up on all systems normally during post or after that. I have tried to plug  in the drive during various phases between pre-bootup and during the linux distro splash screen (menu). Pretty much all options lead to the same conclusion.

In some cases I've had the xbox hdd deciding to go as hdb for some reason if plugging in on the fly (it reverts to hda after a reboot) This usually happens if I have a dummy drive during the initial bootup.

But seriously, I am running out of ideas. I have followed pretty much any option that I have found so far and none of them work. All lead to the same read errors and 'xboxhd' reporting a locked status. 'xbrowser' finds the hdd but of course no partition table.

iirc, the xbox is 1.6 (I found it on a flea market and I pretty much missed the whole xbox thing due to sticking with pc/older consoles) So my knowledge about boxes isn't that broad (altough I do know a ton about computers).
I do have one game tahat I can use to attempt at unlocking (Timesplitters 2)

Currently the xbox drive is forced as a master trough a jumper (Seems to be the best way to get it to be hda each time, + the system detecting it as PRI/MASTER)

Thanks for any possible advice, If you can help trough IM as well then I would appreciate it. ( [maxkyh @ hotmail DOT com] for MSN or catch me on irc as 'oasiz' on quakenet/ircnet/freenode)



  • Guest
The Art Of Hotswapping
« Reply #56 on: July 16, 2010, 07:13:46 PM »

Try with xplorer360 instead: My hdtool.exe actually reports the security status of the hdd from within Windows as well.



  • Guest
The Art Of Hotswapping
« Reply #57 on: July 18, 2010, 05:55:17 AM »

Try with xplorer360 instead: My hdtool.exe actually reports the security status of the hdd from within Windows as well.

THIS worked!

Thousand thankyous ldotsfan, you saved my day!

What I did was simply just play the music like I always did and hotswap this into a usb hdd casing while inside windows 7 x64 (and then power it up), I told xplorer360 to check the drives and it instantly found partitions 0 1 2 3 and 4.
Right now I am backing up the whole drive.
For some reason there was a gta3.img on one partition, I guess the previous owner had his fingers on this one smile.gif

So, if you have a usb hdd casing, follow this post if you have some mysterious problems with the linux-boot method like I had.

And a simple guide for USB hdd case swap, Using a regular cheap USB hdd casing:

1) Open the HDD casing, make sure that it supports the PATA/IDE connector !
   (some even have both, like in my case I had pata/sata and usb+ethernet output).
   NOTE: I Had to swap the data cable to a longer one since the stock cable was around 10cm.

2) Power up your computer and start xplorer360.

3) Do the unlocking ritual on the xbox with any method of your choice, I choose to use audio copy/play and
   it worked from the first try.

4) Unplug the data cable after you are sure that the hdd should now be unlocked
   (play audio for 10 seconds for example and then pause).

5) Plug it into the usb casing, power it up and windows should detect it.

6) In your computer, focus on Xplorer360 window and choose: [Drive] -> [Open] -> [Harddrive or Memcard].

Just wait a few seconds and it should detect the partitions and you are good to go!



  • Guest
The Art Of Hotswapping
« Reply #58 on: July 25, 2010, 04:15:00 PM »

I came up with Error 5 hotswapping a while back but have never seen the true extent of its applications nor document the process in this hotswapping thread. Error 5 hotswapping uses the console error 5 condition to ready an external hdd - the exact mechanism of how this works is unknown. Besides softmod hdd upgrades, a recent event alerted me to the fact that this is in fact a general recovery method if you keep your stock 8/10Gb locked softmod hdd around. With this technique, you can generally recover from softmod errors on your own upgraded hdd or aother console's hdd (provided you have the eeprom.bin or hdd key) without the need of a PC.

Equipment needed:
1. An external power source for the target hdd T . A molex splitter will not work. An USB-IDE enclosure for example.
2. Any UnleashX boot disc. I'll label this lxhdm for easy identification.
3. I'll label console with working softmodded hdd S.

Here's the general process:

1. Eject dvd tray and insert lxhdm dvd. Power off.
2. Connect hdd IDE cable to T's hdd in S's. Supply power to T's hdd.
3. Power on xbox. You will get an error 5 which is expected.
4. Unplug hdd IDE cable but keep external power to T's hdd (in S's)
5. power off xbox and connect hdd IDE cable back to S's hdd.
6. power on and lxhdm dvd will load.
7. when unleashX is loaded, unplug hdd IDE cable from S's hdd and plug it to T's hdd.
8. Use UnleashX file manager , navigate to D drive and launch default.xbe.
9. When UnleashX is relaunched, you have ftp access and the file manager for recovery. Console now 'sees' the T's hdd.

Optional steps is to prep the disc with a working set of softmod files and ConfigMagic for hdd locking/unlocking.

I like the idea that we are using an error condition of the xbox for our objectives of general hdd recovery  jester.gif

Edited by ldotsfan, 26 July 2010 - 12:19 AM.



  • Guest
The Art Of Hotswapping
« Reply #59 on: August 23, 2012, 01:09:35 AM »

Well said.

Pages: 1 2 3 [4]

Page created in 0.121 seconds with 17 queries.